ノンカフェインであなたにやさしい

Rails,HTML,JavaScript,jQuery,PHP,CakePHPなど

Railsでcompass 1.0.1を使う(sass 3.4.9)

Railscompass 1.0.1を使おうとした時に依存関係でコケたのでメモです。

その時のエラー文

ActionView::Template::Error (wrong number of arguments (2 for 1)

バージョン指定なしでインストールした場合

gem 'sass-rails'
gem 'compass-rails'

Gemfile.lockは以下

compass-rails (2.0.0)
  compass (>= 0.12.2)
compass (0.12.7)
  sass (~> 3.2.19)
sass-rails (4.0.3)
  sass (~> 3.2.0)
sass (3.2.19)

compass (0.12.7)になってしまいます。

解決法はsass-rails5.0.0beta1compass-rails2.0.1にすることでcompass 1.0.1を使うことが出来ます。

gem 'sass-rails', '5.0.0beta1'
gem 'compass-rails', '2.0.1'